AmesimKnowledge

The Tools menu > Icon designer

The Icon designer menus

The Icon Designer contains four menus:

File menu

This menu contains the following elements:

  • Open: Open an existing icon to edit it

  • Export SVG: Save an icon to your computer

  • Import image: Import an image from your computer to insert in the icon

  • Close: Close the Icon designer

Edit menu

This menu contains the standard editing tools. You can also use this menu to open the Resize canvas dialog box.

View menu

With this menu, you can adjust the zoom factor, display or hide port labels, toggle the grid on or off, and enable the Snap to grid feature. When Snap to grid is enabled, objects being inserted will be snapped to the nearest grid intersection locations.

Object menu

This menu contains the same options as available in the Advanced toolbar, as described in The Icon designer modes

Source: https://docs.sw.siemens.com/en-US/doc/254352342/PL20250521841123434.amesim_collection.Reference/xid1351451 · retrieved 2026-07-17