Reference Guide for Component Customization > The Component Customization menu bar
File menu
Click on each menu item to display the corresponding information.
Open
File menu Open
This method allows you to select generic or customized objects by name rather than by icon.
To open an object you can also:
click on the button in the toolbar,
use the Ctrl+O shortcut.
If you select Open in the File menu, you will get a file browser to enable you to look for .spe files. Hence you should normally search in the submodels folder of Simcenter Amesim nodes.
You can open .spe files of:
generic submodels,
generic supercomponents,
customized submodels,
customized supercomponents.
Any selected customized object will be loaded into the Component Customization main window.
Note that all successful save operations in Component Customization will always produce customized objects.
Save
File menu Save
Select this menu item when you think your customization is complete and you want to save it. If the customized object is new, Save behaves like Save as.
You can also click on the button in the toolbar or use the Ctrl+S shortcut.
Save as
File menu Save as
Select this menu item when you want to save a customized object with a new name and/or in a different Simcenter Amesim node. You must specify the name and the Simcenter Amesim node.
Note
You can save a customized object as encrypted. If you do this, you will have to set a password. An encrypted objects cannot be opened in Component Customization without its password.
Last opened files list
This section of the menu displays the last opened submodels or supercomponents.
You can change the number of the last opened files to display by using Tools > Options > Component Customization Preferences...
Close
Select this item when you wish to clear the active submodel or supercomponent.
If Component Customization thinks it has changed, you will be invited to save it.
Quit
Select this item when you wish to leave Component Customization. If loaded objects have changed, you will be invited to save them. You can also use the Ctrl+Q shortcut.
Source: https://docs.sw.siemens.com/en-US/doc/254352342/PL20250521841123434.amesim_collection.AMECustom/xid901253 · retrieved 2026-07-17