The Edit menu > Insert
Adding an object to the sketch
Annotation tools Add an instance of an object
Add shapes
Procedure
- In the Edit menu, select Insert > Line, Arrow, Rectangle or Ellipse.
Note You can also select a shape from the Sketch toolbar.
In the sketch area the pointer changes its appearance.
- Proceed according to the type of object:
Annotation tools Adding arrows and lines
Arrows and lines:
Click on the sketch at the start point and for any intermediate point.
Double click for the end point.
Annotation tools Adding rectangles and ellipses
Rectangles and ellipses:
Click on the sketch holding the left button down. This position will define one corner of a box containing the rectangle or ellipse.
Move the pointer and release the button to define the opposite corner of the box.
Add stored images to the sketch
Procedure
- In the Edit menu, select Insert > Image or click on the Insert picture button in the Sketch toolbar.
The Select an Image browser appears.
Browse for the image you require and click on Open.
Select the insertion method you require, Embed or Link.
Note Embedded images are saved in the .ame file and are available to any other users, for example if the model is moved to another machine. Linked images are not saved with the .ame file and must be moved with the document if they are to be available on another machine.
The pointer takes on the form of the selected image.
- Click in the sketch area where you want to place it.
Results
Note
You can drag and drop images onto the Simcenter Amesim Run sketch, for example, from Windows Explorer.
Resize an image
Once your image is placed on the sketch, you can resize it. Click on the image and move your mouse cursor over the handles at each corner. The cursor changes to a double-ended arrow and you can drag the handles to resize the image as you require:
Figure 29: Resizing an image
Note
The aspect ratio is preserved when you drag the corners of an image.
Modify an inserted object or image
Once you have placed your object or your image on the sketch, you can use a right-click to access the following options:
Copy, PasteCopy and paste the object.
OrderWith this menu item, a sub-menu is produced. This can be used when filled objects overlap.Figure 30: Order submenu
Figure 31: Square sent to the background
Edit image link Edit image link Open the Select an Image browser to modify the selected image file.
Embed linked image Embed image Embed the linked image in the sketch. If you need to supply the system to another user, the embedded image will be saved with the system and will be available to the other user.
Edit properties Edit properties You can set a percentage for the transparency attribute for shapes you place on the sketch. In this example, we are placing a rectangle with a black border and a blue center at 81% transparency:Figure 32: Annotation object with transparency
Here is the same rectangle with transparency set to 28%:Figure 33: Annotation object with transparency at 28%
- Set Attributes as Default Set Attributes as Default This applies when an annotation object or text is selected. Any new object added subsequently to the sketch will have the attributes set as default.
Results
This feature applies only when annotation objects other than text are selected.
Source: https://docs.sw.siemens.com/en-US/doc/254352342/PL20250521841123434.amesim_collection.Reference_Run/Adding_an_object_to_the_sketch · retrieved 2026-07-17